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Advanced Features

This course will significantly improve the ease of using the
program and be very helpful in your understanding of TMG.

We will cover the more advanced concepts of:

Data Set Manager, Accents, Focus Groups, Custom Flags,
Advanced Report Options and designing report filters,

Creating Sources and Repositories, Custom Roles, Witnesses,
Sentence Structure, Source Templates, Citation output and
Exporting data.

In addition, companion products including Second Site, and
TMG Utility.
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Introduction

Release
TMG Release 7.00 (UK Version)
Released 30 December 2007

Hardware
Windows 2000, XP, or Vista
Pentium 166 with 64 Megs of
RAM (256 recommended)
A screen resolution of at least
1024x768 is strongly
recommended.
Web searching and chart
uploading features require an
Internet connection.

Personal Usage
2 x One-Name Studies 4,000+
Basis for websites
www.uridge.org
www.pask.org.uk

Other tools
Second Site Version 2 –
generates web pages
TMG Utility – database
modification tool for TMG
Excel
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TMG UK Version

The "UK Edition" is a set of special
UK-oriented customisations that
are automatically applied to a
standard installation of The Master
Genealogist.

English (U.K.) reflects UK spellings
and phrases on the screens and
menus.

Five new UK-oriented timelines

The internal spell checker supports
200+ additional UK spellings.

82 Custom UK source categories
(including Apprenticeship records,
GRO indexes, and others)

Custom tag types, roles, and
sentences, including Census 1841 -
Census 1901; Deportation; Birth
Reg, Death Reg Mar Reg

“The UK edition removes all those
irritating Americanisms that so often
mar otherwise excellent software, and
it replaces them with the UK equivalent
- a big improvement...”
Family Tree Magazine October, 2004
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TMG 7.0 Version – New Functionality

New buttons, and text descriptions
Deactivate in Program Options >
Data Entry
Report Definition screen
The Exhibit Log

Resizing windows

New Reminder Pop-Up Windows for
Tag Types, Sources, and Source
Types

Check for Duplicates While Adding
People

New buttons on the Master Source
List & Source Types allow you to
Export and Import Sources –
exchange with other users

New buttons on the Tag Entry
Screen make it easier to repeat the
previous citation or select from a
list of recent citations

A new button on the Citation Entry
screen allows you to add a new
source without going first to the
Master Source List.
A new Sentence Preview helps you
to predict what a sentence will look
like in a report.
New Associates Window shows
principals and witnesses who
share an event
The List of Witnesses on the Tag
Entry Screen now displays the
specific name variation that has
been associated with that event for
each witness.
The Relationship Calculator and
the Automatic Relationship Tag
now also display relationships as
calculated through the spouse(s) of
one of the two people.
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TMG 7.0 Version – New Functionality

The Picklist and Project Explorer
can now be sorted by the Last
Edited Date.

The Picklist and Project Explorer
now support a variety of multi-level
sorting options.

New Narrative Features

A new sentence code, [+] at the
beginning of a sentence will add it
previous sentence.

A new sentence code, [:NP:] - no
punctuation to the end of the
sentence.

A new standard tag type,
NarrativeChildren, can be used to
override the standard "Children of
X and Y were:" text.

Multimedia Enhancements

Exhibit Highlighting allows you to
"draw" on an image to annotate it.

Option to link Word documents,
Powerpoint presentations or other
non-standard exhibit types.

A new Preferences page (Program
Options > Exhibits) allows you to
specify whether new images that
you add to the Exhibit Log will be
made internal or external by default
(or ask each time).

These are the main new features, there
are many more – see Wholly Genes
Newsletter, 30 December 2007, Issue
2007-20,

or Wholly Genes website
http://www.whollygenes.com/Merchant
2/merchant.mvc?Screen=TMGNEW7
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Data Set Manager, Accents, Focus
Groups, Custom Flags, Advanced Report
Options, Report Filters
Creating Sources and Repositories,
Custom Roles, Witnesses, Sentence
Structure, Source Templates, Citation
Output and Exporting Data
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Help & Aids – Check Out & Use

Preferences

Beginner vs Advanced Mode
Default Basic features (Beginner)

Hot/Repeat Keys
Toolbar or Ctrl Keys
Function (Hot) Keys – F3 repeat
Text Macros

F2 – Access a list of all the places

Last Viewed Person

Bookmarks

Toolbars
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Data Set Manager

The Data Set Manager, allows
you to control and manage the
data sets within your projects.
You can:

Unlock data sets (make
them read/write)
Enable data sets (make
them visible in the Project
Explorer and Picklist)
Create new data sets
Edit data sets

You can create data sets
By importing data from
other researchers -
GEDCOMs
From a sub-set of your own
data

Indicates
locked data set
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Displaying Two Data Sets

Indicates data set 2Indicates
locked data set
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Maintenance – Reindex & Optimise

Regularly  reindex & optimise

Maintenance > Reindex

Followed by

Maintenance > Optimise
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Accents

The Accent feature allows you to
highlight in different colours, depending
on a criteria

Available in many screens

Person, Family, and Tree Views

Children and Siblings window

Project Explorer

Expanded Picklist
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Flag Changes

Before changing Flag changes

Check Preferences > Reports
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Accents: Setting Up

Two-step process

Once you have determined the
criteria – either or field or flag
has a value to match the
criteria.

1. Set up the value. For
example, the Flag xyz = Y.

2. Define the accent.

You can create a flag for most criteria –
standard ones are provided.
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Maintaining Flags

Flags - Identify certain features
Control Accent colours
Select people for various operations

Standard flags:
Sex
Living
Birth Order
Adopted
Multiple Birth
Ancestor Interest
Descendant Interest

Customized flags
Create, Edit, Delete
Enable, Disable
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Accents: Setting the Value – Define a Report

Use the List of People Report



The Master Genealogist, Teresa Pask / 19 uridge@one-name.org

Specify a Filter

Specify the field that
you will base your
criteria on

Add (if applicable)
their

Spouses
Descendants
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Specify the Report Options

Specify the flag
and it’s value

Suppress output
Choose OK, and then on

the Report Definition Screen choose Create Report
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Filter Results

Number of
Descendants

Number of
Spouses

Total People

Flag is changed for all people.
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Define Accent

1. Add New
Accent
Condition

2. Specify New
Accent Condition

3. Define
New Colour

5. Apply
Changes

4. Update
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Focus Group

A focus group is a
collection of individuals
that may be used to specify
Subjects when searching
the web and for other
purposes such as
exporting.

You can save Focus
Groups for later use.
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Focus Group

1. Add Individual

2. Specify new
member

3. Select Descendants
& Spouses, if
applicable

4. Add Others
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Save Focus Group

1. Save Focus Group

2. Specify new group
name, or overwrite
existing group

Focus Group is
created
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Advanced Report Options

Tag types can be
excluded

Index entries can be
included

Report Options can
be created, and used
again and again
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Filters can be created and
used again and again

Filter is to used to find people with a
specific source

This filter is used to identify changes
made to a group of people

Report Filters - Examples
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Break

Let’s have a short break

Only fifteen minutes though!
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Creating Sources

The Master Source List
is a list of all of the
sources recorded in the
project.

The default Master
Source List displays the
Source Abbreviation,
Source Number, Default
Surety, and the number
of times each source
has been cited for each
of the active sources in
the project.

To access the Master
Source List:

From the Tools menu,
select Master Source
List.
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Source Definition: General Tab

Source type –
determines the source
templates, that
contains the sources
fields that will be
printed in narratives

< … > Indicates
whether optional or
mandatory

Defaulted fields can be
overridden in the
output form –
alternatively, you
change the template

<Second Person> in
this instance is used to
record census name
incorrectly transcribed
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Source Type

Source type –
determines the
source templates,
that contains the
sources fields that
will be printed in
narratives

Can be accessed
through the Source
Definition screen, or
Tools > Source Types

< … > Indicates
whether optional or
mandatory
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Source Definition: Output Tab

Source output shows
the sentence
construction as
detailed in the source
template (see
previous slide)

Use the preview to
see how it will appear
in the report, or
narrative.
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Source Definition: Output Tab – Change Default

Source output can be
overridden.

The word
(Overridden)
indicates that is the
case.

Use the preview to
see how it will appear
in the report, or
narrative.
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Creating Repositories

Source is assigned to the
repository in the Source
Definition - Attachment tab

Repositories are used to define where the
source is located. To access the Repository
List:  From the Tools menu, select Master
Repository List. Select the repository

to access the
Repository Definition
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Tags

A tag is a collection of certain fields in which information is stored
about a name, an event, or a relationship.

Event Name for
this event

Witness or
Relationship

Citations / Sources
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Sentences

New sentence structure preview
function provides the sentence
as it will appear in the report, or
narrative.
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Witness Sentence Construction

.

New sentence structure preview
function provides the sentence
as it will appear in the report, or
narrative.
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Tag Sentences Defaults from Tag Type List

The Tag Type List is a
list of all of the tags
detailed in the project.

To access the Tag Type
List :

From the Tools menu,
select Tag Type List .

The Tag Type List
provides:

Sentence

Witness Sentence

Roles and Sentences

Other
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Tag Type Definition – General Tab

Language

Name of Tag

Default  Location Style

If you are using UK version,
ensure that the language and
default style are set correctly.
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Tag Type Definition – Roles and Sentences

Different Roles can have different
sentence structures

You can create new tag types,
and new roles within the tag
types
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Tag Type Definition – Roles and Sentences

You can create new roles within
the tag types
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Tag Type Definition – Other Tab

Short name for
GEDCOM

New feature that can provide
information to remind you when
completing the tag.

Defaults normally suffice
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Export Using a Focus Group: Step 1 & 2
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Exporting Data – Using Focus Group: Step 3 & 4

Select People in the Focus
Group, and then select from the
drop-down the previously
defined focus group

You can use the default
configuration, or create your own
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Exporting Data – Using Focus Group: Step 5 & 6

In Step 5, specify whether to
include ID numbers, sources, and
whether to include living people

In Step 6, specify Tag Types
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Exporting Data – Using Focus Group: Step 7 & 8

After completion of steps 7 & 8, the
system creates the GEDCOM, and
saves it in the location defined in
step 2.
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Companion Products

Second Site – automatically
transforms your genealogy
data into web pages quickly
and easily without knowing
any HTML

TMG Utility – database
modification tool for TMG

How did I create
award winning
websites?

At a push of a button,
and a little help (or
should I say a big
help) from my friend
John Cardinal.
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Second Site - Six easy steps:

1. Start the program Second Site
(available from http://www.johncardinal.com)
TMG should not be running when you use Second Site.

2. Make a “Site Definition File”
Use the File > New... command to make a new Site Definition File (SDF).
Second Site stores the options you select to customize your site in this
file. Select "English - Standard" at the "Read default values from:" prompt.

3. Identify your TMG database
Click the [Set Database...] button in the Data > Database section, navigate
to your TMG database in the File Open dialog, and click [Open].

4. Give your site a title
Key a title in the Pages > Site.Title textbox. Fill in the other textboxes in
the Pages.Site section if you want.

5. Identify yourself
Key your name in the Pages > Compiler.Name textbox. Fill in the other
textboxes in the Pages > Compiler section if you want.

6. Make the site
Use the File > Make Site command to make the site. When Second Site is
done making the site, a window will open with some status messages and
some command buttons. Click the [Browse Site] button to open the main
page of your site.
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Step 2: Make a “Site Definition File”

Use the File > New... command to make a new Site Definition File (SDF).
Second Site stores the options you select to customize your site in this
file. Select "English - Standard" at the "Read default values from:"
prompt.
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Step 3: Identify your TMG database

Click the [Set Database...] button in the Data > Database section,
navigate to your TMG database in the File Open dialog, and click
[Open].
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Step 3: Identify your TMG Database

.

.

All the tags defined in the database
are displayed in the Tags box

You can deselect tags to be
excluded
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Step 4: Give your Site a Title

Key a title in the Pages.Site.Title textbox. Fill in the other
textboxes in the Pages.Site section if you want.
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Site Title - Impact

Second
Site 2

Website: Header
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Step 5: Identify Yourself

Key your name in the Pages > Compiler.Name textbox. Fill in
the other textboxes in the Pages > Compiler section if you
want.

Include Compiler
Section refers to

the information in
TMG Preferences

Second
Site 2

Website: Footer
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Step 6: Make the Site

Use the File > Make Site command to make the site. When Second
Site is done making the site, a window will open with some status
messages and some command buttons. Click the [Browse Site]
button to open the main page of your site.

Progress can be seen in the bar in the
left-hand bottom corner.
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Features in Second Site 2 - Layouts

Multiple layouts –
menu vertical
horizontal, header,
footers
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Features in Second Site 2 – Numerous Styles
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Features: Sample Websites

www.pask.org.uk

http://kerrysdavis.home.c
omcast.net/~kerrysdavis/

There are endless sites listed on
http://www.johncardinal.com/ss/e
xamples.htm.

The choice is yours!

All were achieved using Second
Site.
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TMG Utility

Available from http://www.johncardinal.com
TMG should not be running when you use Second Site.

Demonstration
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Citations

Change Citations changes a
reference from one source
to another source while also
setting the citation detail
(CD). It can be used to
consolidate sources or
make other changes to
source citations.
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Sentences – Rename Language

Rename Language changes
all occurrences of language "A"
in tag types, events, and
names to language "B".

Very useful for converting to
UK Version when upgrading
from US Version
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Using The Master Genealogist  Advanced

I hope that this course has significantly improved the ease of
using the program and is helpful in your understanding of
TMG.

We covered the more advanced concepts of:

Data Set Manager, Accents, Focus Groups, Custom Flags,
Advanced Report Options and designing report filters,

Creating Sources and Repositories, Custom Roles, Witnesses,
Sentence Structure, Source Templates, Citation output and
Exporting data.

In addition, companion products including Second Site, and
TMG Utility.
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More Information: The Master Genealogist

Available from:

TWR COMPUTING
Clapstile Farm, Alpheton, Sudbury, Suffolk, United Kingdom, CO10 9BN
Telephone 01284 828271 http://www.twrcomputing.co.uk/

The Master Genealogist Gold UK Edition v7.0 – download or CD £39.95
Includes free delivery

Or

Wholly Genes Software

www.whollygenes.com

Download only: (includes electronic Users Guide*) $59.00

Upgrade from 6.0 to 7.0  $29.95

There is an option to download a 30-day free trial (43.4 Megs)
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More Information: Web Sites

My websites www.uridge.org www.pask.org.uk

TMG User Group

http://www.rootsweb.com/~ohcagg/tmg/ lists lots of links,
handouts, information etc.

Caroline Gurney

http://homepage.ntlworld.com/caroline.gurney1/TMG.htm
provides UK Source Templates, Timelines, UK Place Styles,
TMG Layouts, Tags and Sentences

SecondSite & TMG Utility

http://www.johncardinal.com/


